Jump to content

eac

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. Where can I find the beta drivers? Where can I find these beta drivers?
  2. Fixed it! Added the following to /etc/udev/hwdb.d/71-mouse-local.hwdb (the path may change depending on your distro): mouse:usb:v214Ep0005:name:Swiftpoint Z MOUSE_WHEEL_CLICK_ANGLE=30 MOUSE_WHEEL_CLICK_COUNT=12 Not 100% sure about the values, but they seem to work just fine. Then I ran "udevadm hwdb --update" and replugged the mouse to pick up the config changes (there's probably a way to do that live but I didn't bother looking). edit: I spoke too soon. Seems like the fix is replugging it in linux; when it comes up on boot it comes up with the too fast scrolls.
  3. Dug in a bit more. Turns out the axis values for the swiftpoint Z are far too high in linux: event16 POINTER_AXIS +4.93s vert 1800.00* horiz 0.00 (wheel) event16 POINTER_AXIS +4.96s vert 1800.00* horiz 0.00 (wheel) Note the 1800, vs: event26 POINTER_AXIS +4.12s vert 15.00* horiz 0.00 (wheel) event26 POINTER_AXIS +4.18s vert 15.00* horiz 0.00 (wheel) for a "normal" mouse. Haven't figured out if I can adjust a multiplier or something on this yet.
  4. Tried that, no luck, unfortunately
  5. It is set to 1 line in the windows driver, and the scrolling works as expected in windows. In linux, other mice scroll properly, just the Z mouse that scrolls page by page. As far as configuration goes, this is what is exposed: Device 'Swiftpoint Limited Swiftpoint Z': Device Enabled (152): 1 Coordinate Transformation Matrix (154): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000 libinput Natural Scrolling Enabled (286): 0 libinput Natural Scrolling Enabled Default (287): 0 libinput Scroll Methods Available (288): 0, 0, 1 libinput Scroll Method Enabled (289): 0, 0, 0 libinput Scroll Method Enabled Default (290): 0, 0, 0 libinput Button Scrolling Button (291): 2 libinput Button Scrolling Button Default (292): 2 libinput Middle Emulation Enabled (293): 0 libinput Middle Emulation Enabled Default (294): 0 libinput Accel Speed (295): 0.000000 libinput Accel Speed Default (296): 0.000000 libinput Accel Profiles Available (297): 1, 1 libinput Accel Profile Enabled (298): 1, 0 libinput Accel Profile Enabled Default (299): 1, 0 libinput Left Handed Enabled (300): 0 libinput Left Handed Enabled Default (301): 0 libinput Send Events Modes Available (271): 1, 0 libinput Send Events Mode Enabled (272): 0, 0 libinput Send Events Mode Enabled Default (273): 0, 0 Device Node (274): "/dev/input/event16" Device Product ID (275): 8526, 5 libinput Drag Lock Buttons (302): <no items> libinput Horizontal Scroll Enabled (303): 1 Device 'Swiftpoint Limited Swiftpoint Z Consumer Control': Device Enabled (152): 1 Coordinate Transformation Matrix (154): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000 libinput Natural Scrolling Enabled (286): 0 libinput Natural Scrolling Enabled Default (287): 0 libinput Send Events Modes Available (271): 1, 0 libinput Send Events Mode Enabled (272): 0, 0 libinput Send Events Mode Enabled Default (273): 0, 0 Device Node (274): "/dev/input/event18" Device Product ID (275): 8526, 5 libinput Drag Lock Buttons (302): <no items> libinput Horizontal Scroll Enabled (303): 1 I've tried tweaking some of the settings but I can't find any that make a difference.
  6. In linux, the mouse wheel is SUPER sensitive -- a single button press on the mousewheel will do a page-up / page-down vs. scrolling line by line. Does anyone else have this issue and/or found a workaround? I can't find any settings in xinput that seem to adjust the sensitivity of the scrollwheel.
×
×
  • Create New...