Jump to content
Carl Edman

Z-Mouse Blocks Game Controller

Recommended Posts

In many, but not all, games I play with controller support, having the Z-Mouse plugged-in blocks recognition of my actual game controller (a Steam Controller in my case).  Two things which do not help: 1. Changing the "Game Controller Type" in the Swiftpoint configuration panel to "None".  2. Changing the priority in the "Set up USB Game Controller" configuration panel.  The only thing that works is unplugging the Z-Mouse before starting the game.  Which is inconvenient.

Any advice?

Share this post


Link to post
Share on other sites

Is this happening with every game you try to play with controller or a specific one?

I too have steam controller, but haven't noticed it being interfered by the Z.

Have you tried to enable support for different controller types in the controller general settings, as some games do not natively support steam controller?

steam_settings.jpg.4823b47003f87bc9bc0072ad49ef4b7e.jpg

steam_controller.thumb.jpg.8a6e902f9606a3cd18980b6d16aae3b3.jpg

Share this post


Link to post
Share on other sites

No, not every game.  For example, it doesn't happen with Legend of Heroes: Trails of Cold Steel 1, but it does happen with LOH: TCS 2.

Also I don't think that the problem is compatibility with the Steam Controller because if I unplug the Z Mouse before starting LOH: TCS 2, it works just fine with the Steam Controller without any other configuration changes.

Share this post


Link to post
Share on other sites

So I had a little go around with few games and so far it could be that for some reason your steam controller is using it's desktop setup in LOH: TCS 2 which is sure to default the controller to swiftpoint z, you could try to make a specific steam controller scheme for it or as last resort try if switching out the desktop setup into controller would correct this.

Share this post


Link to post
Share on other sites

Any update on this?  I still have the same problem with the same games.  The only thing that works is unplugging the Z-Mouse every time I play one of these games.  You can even plug it right back in after the game starts and the controller will work, but this is inconvenient.  I'd hate to wear out the Z-Mouse USB socket by pulling it out and replugging it in several times a day.

PS: I do use the latest public driver updated just today.

Share this post


Link to post
Share on other sites

@Carl Edman If the Z's controller outputs are causing problems you can disable them from device manager with the steps below. 

  1. Open device manager by pressing "Windows Key + X", to open the windows tool menu. Then press 'M' for Device Manager", or select it from the menu.
  2. In Device Manager expand the "Human Interface Devices" category, then right click the "HID-compliant game controller" and select "Disable device".image.png.6cd25da8c71d4a858b2f5c5d162cab
  3. It can then be enabled again in the same way when needed.

Share this post


Link to post
Share on other sites

Thanks for the suggestion, @Bryce!  Unfortunately it won't quite work as I need to move the mouse cursor over the desktop icon of the game before I disable/unplug it.  Then I can just hit return to start the game (and plug the mouse right back in after the game starts).

Share this post


Link to post
Share on other sites
7 hours ago, Carl Edman said:

Thanks for the suggestion, @Bryce!  Unfortunately it won't quite work as I need to move the mouse cursor over the desktop icon of the game before I disable/unplug it.  Then I can just hit return to start the game (and plug the mouse right back in after the game starts).

With the approach I mentioned you won't need to unplug your mouse, and your Z will still function normally; other than its joystick outputs being disabled.

So unless there is something I'm missing, it should work,

Share this post


Link to post
Share on other sites

Thanks, @Bryce!   This actually worked.  Sorry for misunderstanding your advice originally as disabling the mouse completely.

I wish that one could easily disable/reenable this by mouse mode.  Unfortunately setting "Game Controller Type" in the Swiftpoint Settings to "None" does not work.

Share this post


Link to post
Share on other sites

@Carl Edman I'm glad to hear that worked. 

Eventually we do plan to make the "Game Controller Type" setting work in a similar way to disabling it in device manager.

Currently it disables the individual controller outputs, but not the whole controller interface. Which unfortunately isn't enough to prevent this issue on its own.

Share this post


Link to post
Share on other sites
Posted (edited)

To anyone who recently has been playing Sekiro, that game also has this issue and it took me forever to realize I needed to unplug the mouse to get my XB1 controller to work.

Edited by CasePB

Share this post


Link to post
Share on other sites
On 3/26/2019 at 4:26 PM, CasePB said:

To anyone who recently has been playing Sekiro, that game also has this issue and it took me forever to realize I needed to unplug the mouse to get my XB1 controller to work.

Was your xbox 1 controller connected with the wired ?
Because I had 0 issue with my mouse plugged and the xbox 1 in wireless mode. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...