Jump to content

Feature Request: no game controller


Recommended Posts

This has come up on enough games for it to be an irritating problem for me - mainly because it happens infrequently enough that I forget this is a problem and spend far too long troubleshooting it. I never use this thing as a game controller, yet it stays at the top of the list of game controllers connected to the system. The problem being, some poorly coded games - usually console ports - only accept input from the first controller on the list. The list is shown inside of the Game Controllers control panel(joy.cpl) and uses some odd system that's difficult to manipulate. In fact, I only know of one way. Physically remove the device from the machine to remove it from the list.

In practice, this means I have to unplug the mouse before I start Sekiro for example in order to use a gamepad. This sucks. Sekiro isn't completely horrible(in spite of lacking ultrawide support and being locked at 60fps) and this means I can plug the mouse back in once it starts as it latches onto whatever was #1 when it initializes. More recently however, Genshin Impact will just freeze when I plug the mouse back in.

This isn't your fault at all. But please fix it because bad console ports aren't going anywhere. Give me the option to not have Swiftpoint Z show up as a game controller. Please. I have cherished this mouse for over two years now and have never used it as a controller. This feature on this gaming mouse is only a hindrance to my enjoyment of games.

Link to post
Share on other sites

As already stated and as Bryce mentioned in at least one post/tutorial, you can go into device manager and disable(not uninstall, just disable) the game controller HID associated with the Z.

I also had to do this, because certain games like mirrors edge can not handle controller and mouse being connected at once and just go spinning, when there is a controller present

  • Thanks 2
Link to post
Share on other sites
10 hours ago, Zeanon said:

As already stated and as Bryce mentioned in at least one post/tutorial, you can go into device manager and disable(not uninstall, just disable) the game controller HID associated with the Z.

I also had to do this, because certain games like mirrors edge can not handle controller and mouse being connected at once and just go spinning, when there is a controller present

Thanks for the follow up @Zeanon 

This seems to have worked for me. However it required guesswork within the device manager under the HID controller category as the SwiftpointZ does not call itself out like Logitech and Corsair do. It just generically says "Game Controller Device" or something.

Also, after a search within the forums I wasn't able to find the post from Bryce that you mentioned. If you could post a link that might help some googler who comes upon this post.

Link to post
Share on other sites
On 10/3/2020 at 12:46 PM, Wykillin said:

The workaround doesn't seem to work anymore

Strange, it should still be working.

If you go to the "Game Controllers" dialog, does it still list the Swiftpoint Z? (search game controllers in the start menu to find this dialog)

If your Z is still listed you may have disabled the wrong "HID-compliant game controller" in device manager. So try disabling them one by one until the Z disappears from your Game Controller list.

image.png.a3312b12cdbf4d354c2971a3041b05ac.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...