Jump to content

New Swiftpoint control panel feedback


Recommended Posts

Hey!

Thanks for listening to the community and keeping us toghether! ❤️

I just found this tiny bug:

These are my settings (0.040 seconds)

1605209102.png.87b408616a98ee86ff9ddbd36aed0bff.png

but this is how it gets displayed:

1605209113.png.abc5deb3a0288a0be13373235b5d626f.png

Tiny bug.

Also some feedback on the new tilt icons.

The new ones:

1605209236.png.fd76fede93c8f3764030e068dedff8ba.png

Versus a suggestion (using the old icons):

1603592457.thumb.png.905a95657e302609dea739893d91f8fe.png.134033b69e1cec451e386e593ca29529.png

Having it called roll, pitch, and yaw is increadibly useful specially because the joystick functionality is heavily advertised. Using 3 words for 3 different movements really helps! Specially foreigners and people who are not fluent in the language. They will spot the terms in the game / app and be able to quickly find the corresponding term within the mouse. 

Thanks a lot for listening.

These are just suggestions.

EDIT:

Another tiny suggestion: Allow us to CTRL+CLICK to select multiple executables during the linking process. This helps when the executable has multiple versions (32, 64, Vulkan, Test Server)

1605209760.thumb.png.c12fb113b8e287c391682182b2caec33.png

PS: Hope you guys eventually develop a mechanical keyboard. Maybe something like the Dygma Raise, but with the Z's customization level? Oh that would be absolutely perfect. Maybe add a modular + magnetic design to it? So that people buy different addons? Jeez. I'm already saving up. TAKE MY MONEY!

Edited by untag
  • Thanks 1
Link to post
Share on other sites

@untag Thanks for the report and the feedback.

It looks like the wait duration was setup to always display as milliseconds on this screen, while the unit shown is always 's'.

I've adjusted this now so it should only use milliseconds when appropriate and display the correct unit either way. This will be included in the next update.

I agree that the tilt icons could do with some revising, so will pass this feedback on to our designer.

On 11/13/2020 at 8:33 AM, untag said:

Another tiny suggestion: Allow us to CTRL+CLICK to select multiple executables during the linking process. This helps when the executable has multiple versions (32, 64, Vulkan, Test Server)

In most cases even when there are multiple exe's you should only need to link one. But we plan to revise the system for linking apps to profiles so browsing for exe's generally wont be required at all. Which should bypass this issue either way.

 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...