Jump to content
Ramulus

Auto assign DPI when profile switching?

Recommended Posts

Hi,

As the title reads, is there any way to select a custom DPI for specific games vs desktops when I switch to that profile? Another issue is that I manually have to switch to the gaming profile I want since I cannot figure out auto profile switching. Any info would be great.

Thanks! 

Share this post


Link to post
Share on other sites

Profile specific DPI settings are available under the "<Profile> Settings" screen (e.g. Desktop Settings), accessed with the button at the left of the window.

If you do not see the DPI slider here this profile will be using the DPI from the Global Default profile. But if you click the "+ADD settings to override Global" button you can set a DPI just for this profile.

image.png.cef3e91c2174c7593cbbfac87089445c.png

 

Linking applications to profiles for auto profile switching is done from this same screen. Just click "+Add Application" at the top right of the screen and find the executable for the game or application you want to link.

This is sometimes easier said than done, but if you're not sure where the executable is for a particular game is a google search should put you in the right direction (e.g. "where is the dota 2 executable").

Once you have linked an application to a profile,  you then just need to make sure your 'Active Profile' in the driver is set to 'Auto Profile Switching'.

image.png.46e11060fbc417b70706cc5051dd6f17.png

Share this post


Link to post
Share on other sites

Hi,

Thanks for your response. It seems to be working. However, when I have the software for Swiftpoint on the other screen, I don't notice it switching to the actual game profile I created. But I know it's working because when the game launches, the correct functions work. Is there something I missed that offers me a visual clue that the profiles are switching? 

And just to be clear, once the game ends, it defaults to desktop, correct? Because that has a different DPI higher than my game. Like I said, it's working, but without any visual cues, I didn't know it was at first. 

Love this mouse! Thanks again. 

Share this post


Link to post
Share on other sites

In the UI the currently active profile is shown with an '*' in-front of its name on the profile bar. So you should see this move when you profiles automatically swap. Alternatively though you can display the current profile on your Z's OLED screen. Just set 'OLED Mode'  to 'Current Profile' under "Global Defaults > Global Settings" (you may also need to change this setting on your other profiles if they have it set to something different).

As you suspected whenever you switch focus to an application which is not linked to any of your profiles, your 'Default' profile will be loaded. This will be the Desktop profile initially, but you can set it to any other profile by going to its "<profile> settings" screen and ticking the "Set as Default Profile" checkbox at the top right corner.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...